<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.financialwatchngr.com/xmlrpc.php" />
<title>How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca] &raquo; Financial Watch</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Montréal or visit family in Toronto for your annual Christmas"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca] &raquo; Financial Watch" />
<meta property="og:description" content="Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Montréal or visit family in Toronto for your annual Christmas" />
<meta property="og:url" content="https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/" />
<meta property="og:site_name" content="Financial Watch" />
<meta property="article:publisher" content="https://web.facebook.com/FinancialWatchNigeria/" />
<meta property="article:author" content="https://web.facebook.com/" />
<meta property="article:section" content="Business" />
<meta property="article:published_time" content="2020-03-05T10:44:20+00:00" />
<meta property="article:modified_time" content="2020-03-05T10:45:15+00:00" />
<meta property="og:updated_time" content="2020-03-05T10:45:15+00:00" />
<meta property="og:image" content="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg" />
<meta property="og:image:secure_url" content="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="500" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Montréal or visit family in Toronto for your annual Christmas" />
<meta name="twitter:title" content="How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca] &raquo; Financial Watch" />
<meta name="twitter:site" content="@financialwatchn" />
<meta name="twitter:image" content="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg" />
<meta name="twitter:creator" content="@financialwatchn" />
<meta name="geo.placename" content="Festac, Lagos" />
<meta name="geo.region" content="NG" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>
<!-- / Yoast SEO Premium plugin. -->
<link rel="amphtml" href="https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/amp/" /><meta name="generator" content="AMP for WP 1.0.31"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; Feed" href="https://www.financialwatchngr.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; Comments Feed" href="https://www.financialwatchngr.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca] Comments Feed" href="https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.financialwatchngr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<!-- <link rel='stylesheet' id='wp-block-library-css'  href='https://www.financialwatchngr.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1582784088' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://www.financialwatchngr.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='orbisius_ct_mh_magazine_child_theme_parent_style-css'  href='https://www.financialwatchngr.com/wp-content/themes/mh-magazine/style.css?ver=3.9.3' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='orbisius_ct_mh_magazine_child_theme_parent_style_child_style-css'  href='https://www.financialwatchngr.com/wp-content/themes/mh-magazine-child-theme/style.css?ver=3.8.3' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://www.financialwatchngr.com/wp-content/themes/mh-magazine-child-theme/style.css?ver=3.9.3' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.financialwatchngr.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//www.financialwatchngr.com/wp-content/cache/wpfc-minified/qksao65o/h9gvx.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather+Sans' type='text/css' media='all' />
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.9.3'></script>
<link rel='https://api.w.org/' href='https://www.financialwatchngr.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.financialwatchngr.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.financialwatchngr.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.financialwatchngr.com/?p=1243' />
<link rel="alternate" type="application/json+oembed" href="https://www.financialwatchngr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.financialwatchngr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F&#038;format=xml" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script> (adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-4174590025316317", enable_page_level_ads: true }); </script><meta name="google-site-verification" content="oOQR81Es3VTwmx8bdp6EEOCq6aQJ9tybanSWODii0uM" />
<meta name="google-site-verification" content="oOQR81Es3VTwmx8bdp6EEOCq6aQJ9tybanSWODii0uM" />
<meta name="msvalidate.01" content="B7898B7005E5E6C97EF3453297089F48" />
<script async custom-element="amp-auto-ads"
src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js">
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4174590025316317",
enable_page_level_ads: true
});
</script>
<!-- Markup (JSON-LD) structured in schema.org ver.4.7.0 START -->
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@id": "https://www.financialwatchngr.com/category/business/",
"name": "Business"
}
},
{
"@type": "ListItem",
"position": 2,
"item": {
"@id": "https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/",
"name": "How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]"
}
}
]
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "Organization",
"name": "Financial Watch ",
"url": "https://www.financialwatchngr.com/",
"logo": "https://www.financialwatchngr.com/wp-content/uploads/2017/01/logo-fwn.png",
"contactPoint": [
{
"@type": "ContactPoint",
"telephone": "+2348141171945",
"contactType": "customer service",
"email": "financialwatchngr@gmail.com",
"areaServed": [
"NG"
],
"contactOption": [
"HearingImpairedSupported"
],
"availableLanguage": [
"English"
]
}
],
"sameAs": [
"https://web.facebook.com/FinancialWatchNigeria/",
"https://twitter.com/financialwatchn",
"https://www.youtube.com/channel/UC8h8kLZIjHy-z57n8_Dyk0Q",
"https://www.linkedin.com/company-beta/11112395/"
]
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "SiteNavigationElement",
"name": [
"PRICE WATCH",
"Job Past Questions",
"Privacy Policy",
"Careers",
"Disclaimer"
],
"url": [
"https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/",
"https://www.financialwatchngr.com/category/job-past-questions/",
"https://www.financialwatchngr.com/privacy-policy/",
"https://www.financialwatchngr.com/category/careers/",
"https://www.financialwatchngr.com/disclaimer/"
]
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "WebSite",
"name": "Financial Watch ",
"alternateName": "Business News In Nigeria",
"url": "https://www.financialwatchngr.com/",
"potentialAction": [
{
"@type": "SearchAction",
"target": "{search_term_string}",
"query-input": "required name=search_term_string"
},
{
"@type": "SearchAction",
"target": "{search_term_string}",
"query-input": "required name=search_term_string"
}
]
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "Article",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/"
},
"headline": "How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]",
"datePublished": "2020-03-05T11:44:20+0100",
"dateModified": "2020-03-05T11:45:15+0100",
"author": {
"@type": "Person",
"name": "Haruna Magaji"
},
"description": "Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Mon",
"image": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg",
"width": 900,
"height": 500
},
"publisher": {
"@type": "Organization",
"name": "Financial Watch Newspaper",
"logo": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2018/04/amp-1.png",
"width": 600,
"height": 60
}
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BlogPosting",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/"
},
"headline": "How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]",
"datePublished": "2020-03-05T11:44:20+0100",
"dateModified": "2020-03-05T11:45:15+0100",
"author": {
"@type": "Person",
"name": "Haruna Magaji"
},
"description": "Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Mon",
"image": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg",
"width": 900,
"height": 500
},
"publisher": {
"@type": "Organization",
"name": "Financial Watch Newspaper",
"logo": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2018/01/logo-article.jpg",
"width": 600,
"height": 60
}
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.financialwatchngr.com/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/"
},
"headline": "How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]",
"datePublished": "2020-03-05T11:44:20+0100",
"dateModified": "2020-03-05T11:45:15+0100",
"author": {
"@type": "Person",
"name": "Haruna Magaji"
},
"description": "Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Mon",
"image": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg",
"width": 900,
"height": 500
},
"publisher": {
"@type": "Organization",
"name": "Financial Watch",
"logo": {
"@type": "ImageObject",
"url": "https://www.financialwatchngr.com/wp-content/uploads/2018/04/amp-1.png",
"width": 600,
"height": 60
}
},
"speakable": {
"@type": "SpeakableSpecification",
"cssSelector": [
"",
""
]
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "Organization",
"name": "Financial Watch ",
"url": "https://www.financialwatchngr.com/",
"logo": "https://www.financialwatchngr.com/wp-content/uploads/2017/01/logo-fwn.png",
"contactPoint": [
{
"@type": "ContactPoint",
"telephone": "+2348141171945",
"contactType": "customer service",
"email": "financialwatchngr@gmail.com",
"areaServed": [
"NG"
],
"contactOption": [
"HearingImpairedSupported"
],
"availableLanguage": [
"English"
]
}
],
"sameAs": [
"https://web.facebook.com/FinancialWatchNigeria/",
"https://twitter.com/financialwatchn",
"https://www.youtube.com/channel/UC8h8kLZIjHy-z57n8_Dyk0Q",
"https://www.linkedin.com/company-beta/11112395/"
]
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "WebSite",
"name": "Financial Watch ",
"alternateName": "Business News In Nigeria",
"url": "https://www.financialwatchngr.com/",
"potentialAction": [
{
"@type": "SearchAction",
"target": "{search_term_string}",
"query-input": "required name=search_term_string"
},
{
"@type": "SearchAction",
"target": "{search_term_string}",
"query-input": "required name=search_term_string"
}
]
}
</script>
<!-- Markup (JSON-LD) structured in schema.org END -->
<style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #6b6b6b; }
.mh-extra-nav-bg { background: rgba(107, 107, 107, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #6b6b6b; background: rgba(107, 107, 107, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(107, 107, 107, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #6b6b6b; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #5b5b5b; background: rgba(91, 91, 91, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #5b5b5b; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #5b5b5b; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #5b5b5b; }
.mh-subheader, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget .search-form, .mh-tab-button, .mh-tab-content, .mh-nip-widget, .mh-magazine-facebook-page-widget, .mh-social-widget, .mh-posts-horizontal-widget, .mh-ad-spot, .mh-info-spot { background: #595959; }
.mh-tab-post-item { border-color: rgba(255, 255, 255, 0.3); }
.mh-tab-comment-excerpt { background: rgba(255, 255, 255, 0.6); }
.mh-header-nav-bottom li a, .mh-social-nav-bottom .fa-mh-social, .mh-boxed-layout .mh-ticker-item-bottom a, .mh-header-date-bottom, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout3 .mh-widget-title a, .mh-tabbed-widget, .mh-tabbed-widget a, .mh-posts-horizontal-title a { color: #fcfcfc; }
.entry-content a { color: #dd0000; }
a:hover, .entry-content a:hover, #respond a:hover, #respond #cancel-comment-reply-link:hover, #respond .logged-in-as a:hover, .mh-comment-list .comment-meta a:hover, .mh-ping-list .mh-ping-item a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #dd3333; }
</style>
<!--[if lt IE 9]>
<script src="https://www.financialwatchngr.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather Sans", sans-serif; }
body { font-family: "Merriweather Sans", sans-serif; }
</style>
<meta name="onesignal" content="wordpress-plugin"/>
<script>
window.OneSignal = window.OneSignal || [];
OneSignal.push( function() {
OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };
OneSignal.setDefaultNotificationUrl("https://www.financialwatchngr.com");
var oneSignal_options = {};
window._oneSignalInitOptions = oneSignal_options;
oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'f4ce5e76-1a00-43d3-8e7f-b222251af2cc';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.financialwatchngr.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
OneSignal.init(window._oneSignalInitOptions);
OneSignal.showSlidedownPrompt();      });
function documentInitOneSignal() {
var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");
var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
}
if (document.readyState === 'complete') {
documentInitOneSignal();
}
else {
window.addEventListener("load", function(event){
documentInitOneSignal();
});
}
</script>
<style type="text/css">.broken_link, a.broken_link {
text-decoration: line-through;
}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="icon" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-270x270.png" />
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-1243 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<div class="mh-header-date mh-header-date-top">
March 5, 2020						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="menu-social-icons-container"><ul id="menu-social-icons" class="menu"><li id="menu-item-38323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38323"><a href="https://web.facebook.com/FinancialWatchNigeria/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">FACEBOOK</span></a></li>
<li id="menu-item-38324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38324"><a href="https://twitter.com/financialwatchn"><i class="fa fa-mh-social"></i><span class="screen-reader-text">TWITTER</span></a></li>
<li id="menu-item-38325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38325"><a href="https://www.youtube.com/channel/UC8h8kLZIjHy-z57n8_Dyk0Q"><i class="fa fa-mh-social"></i><span class="screen-reader-text">YOUTUBE</span></a></li>
<li id="menu-item-38913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38913"><a href="https://www.linkedin.com/company-beta/11112395/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">LINKEDIN</span></a></li>
<li id="menu-item-38326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38326"><a href="https://www.financialwatchngr.com/feed/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">RSS</span></a></li>
</ul></div>						</nav>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-1 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://www.financialwatchngr.com/" class="custom-logo-link" rel="home"><img width="200" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2020/01/cropped-financialwatch2020.png" class="custom-logo" alt="cropped financialwatch" /></a></div>
</div>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-75935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75935"><a href="https://www.financialwatchngr.com/">HOME</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.financialwatchngr.com/category/banking-news-in-nigeria/">Banking</a></li>
<li id="menu-item-79729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79729"><a href="https://www.financialwatchngr.com/category/economy/">ECONOMY</a></li>
<li id="menu-item-84856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84856"><a href="https://www.financialwatchngr.com/category/latest-news/">HEADLINES</a></li>
<li id="menu-item-79727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79727"><a href="https://www.financialwatchngr.com/category/view-point/">VIEW POINT</a></li>
<li id="menu-item-79933" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79933"><a href="https://www.financialwatchngr.com/category/business/">Business</a></li>
<li id="menu-item-79934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79934"><a href="https://www.financialwatchngr.com/category/metro/">Metro</a></li>
<li id="menu-item-79935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79935"><a href="https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/">PRICE WATCH</a></li>
</ul></div>		</nav>
</div>
<div class="mh-extra-nav-wrap">
<div class="mh-extra-nav-bg">
<nav class="mh-navigation mh-extra-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="menu-below-main-menu-container"><ul id="menu-below-main-menu" class="menu"><li id="menu-item-79929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79929"><a href="https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/">PRICE WATCH</a></li>
<li id="menu-item-79928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79928"><a href="https://www.financialwatchngr.com/category/job-past-questions/">Job Past Questions</a></li>
<li id="menu-item-79922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-79922"><a href="https://www.financialwatchngr.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-79930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79930"><a href="https://www.financialwatchngr.com/category/careers/">Careers</a></li>
<li id="menu-item-79923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79923"><a href="https://www.financialwatchngr.com/disclaimer/">Disclaimer</a></li>
</ul></div>				</nav>
</div>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
JUST IN<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/03/03/uba-business-unveils-office-at-new-ultra-modern-afriland-towers-photos/" title="UBA Business unveils Office at New Ultra-modern Afriland Towers (PHOTOS)">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 3, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
UBA Business unveils Office at New Ultra-modern Afriland Towers (PHOTOS)						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/03/03/gtbank-releases-2019-full-year-audited-results/" title="GTBank Releases 2019 Full Year Audited Results">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 3, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
GTBank Releases 2019 Full Year Audited Results						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/28/why-gtbank-will-win-digital-payment-space-segun-agbaje/" title="Why GTBank will win Digital Payment Space — Segun Agbaje">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 28, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Why GTBank will win Digital Payment Space — Segun Agbaje						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/26/uba-launches-more-quick-loan-for-salary-earners/" title="UBA launches more Quick Loan For Salary Earners">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 26, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
UBA launches more Quick Loan For Salary Earners						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/26/banks-must-get-approval-before-sacking-more-than-5-staff-cbn/" title="Banks must get approval before sacking more than 5 staff &#8211; CBN">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 26, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Banks must get approval before sacking more than 5 staff &#8211; CBN						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/24/cbn-clarifies-policy-on-transactions-in-domiciliary-accounts/" title="CBN clarifies policy on transactions in domiciliary accounts">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 24, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
CBN clarifies policy on transactions in domiciliary accounts						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/21/stanbic-ibtc-aims-to-groom-future-business-leaders-through-yls/" title="Stanbic IBTC Aims To Groom Future Business Leaders Through YLS">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 21, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Stanbic IBTC Aims To Groom Future Business Leaders Through YLS						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/21/cbn-refunds-over-n60-billion-excess-charges-to-bank-customers/" title="CBN refunds Over N60 Billion Excess Charges to bank Customers">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 21, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
CBN refunds Over N60 Billion Excess Charges to bank Customers						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/16/access-bank-relocates-head-office/" title="Access Bank relocates head office">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 16, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Access Bank relocates head office						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://www.financialwatchngr.com/2020/02/13/access-bank-speaks-on-ceo-herbert-wigwes-alleged-arrest/" title="Access Bank speaks on CEO, Herbert Wigwe&#8217;s alleged Arrest">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Access Bank speaks on CEO, Herbert Wigwe&#8217;s alleged Arrest						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
BANKING							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://www.financialwatchngr.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.financialwatchngr.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.financialwatchngr.com/category/business/" itemprop="item"><span itemprop="name">Business</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]</nav>
<article id="post-1243" class="post-1243 post type-post status-publish format-standard has-post-thumbnail hentry category-business">
<header class="entry-header clearfix"><h1 class="entry-title">How to Apply for a Canadian Visa from Nigeria in 2020 [www.cic.gc.ca]</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/03/">March 5, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.financialwatchngr.com/author/max24/">Haruna Magaji</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.financialwatchngr.com/category/business/" rel="category tag">Business</a></span>
</div>
</header>
<div id="text-37" class="mh-widget mh-posts-1 widget_text">			<div class="textwidget"><p>Looking for job? your search ends here! Visit <a href="https://recruitmentportalngr.com/"><span style="color: #ff0000;"><strong>https://recruitmentportalngr.com/</strong></span> </a> to apply now OR Send us a <strong><span style="color: #ff0000;"><a style="color: #ff0000;" href="https://recruitmentportalngr.com/how-to-create-ads-submit-cvs-find-jobs-cvs-on-martify-com-ng/">WhatsApp Message here!</a></span></strong></p>
</div>
</div><div id="text-45" class="mh-widget mh-posts-1 widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- link ads 2020 --><br />
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4174590025316317"
data-ad-slot="6898654848"
data-ad-format="link"
data-full-width-responsive="true"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div>	<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020-678x381.jpg" alt="Canada Visa Application" title="Canada Visa Application" />
<figcaption class="wp-caption-text">Canada Visa Application</figcaption>
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F&t=How+to+Apply+for+a+Canadian+Visa+from+Nigeria+in+2020+%5Bwww.cic.gc.ca%5D', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=How+to+Apply+for+a+Canadian+Visa+from+Nigeria+in+2020+%5Bwww.cic.gc.ca%5D:&url=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2020%2F03%2F05%2Fhow-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca%2F&media=https://www.financialwatchngr.com/wp-content/uploads/2019/05/Canada-Visa-Application-2020.jpg&description=How+to+Apply+for+a+Canadian+Visa+from+Nigeria+in+2020+%5Bwww.cic.gc.ca%5D', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-email" href="/cdn-cgi/l/email-protection#033c707661696660773e4b6c74263133776c2631334273736f7a263133656c712631336226313340626d62676a626d263133556a706226313365716c6e2631334d6a6466716a622631336a6d263133313331332631332636417474742d606a602d64602d606226364725626e7338616c677a3e6b777773702630422631452631457474742d656a6d626d606a626f746277606b6d64712d606c6e26314531333133263145333026314533362631456b6c742e776c2e6273736f7a2e656c712e622e60626d62676a626d2e756a70622e65716c6e2e6d6a6466716a622e6a6d2e313331332e7474742e606a602e64602e6062263145" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<p>Whether it is your first time travelling to Canada or you are returning to rediscover the cultural buzz of Montréal or visit family in Toronto for your annual Christmas get together, you will need a visa to get you there. With this step-by-step guide to the <strong>Tourist Visa </strong>application process, your dreams of exploring this country where no dream is too big and anything is possible just became a little less complicated. <a href="https://recruitmentportalngr.com/tag/visa-application/">Click here to see how to apply for visa to any country in the world.</a></p>
<div class="mh-content-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250 display and texts -->
<ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-4174590025316317"
data-ad-slot="4166864987"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Nigerian passport holders do require a tourist visa to visit Canada. Visa applications need to be submitted online through the IRCC online application system or through the VFS Global Canadian Visa Application Centre in Lagos or Abuja. We recommend checking your <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">eligibility</a> before beginning the application process and submitting your application in advance of flight departure. Then, once you have your visa, all you need to do is plan your trip, <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">book your tickets</a>, and pack your bags!</p>
<figure id="attachment_89105" aria-describedby="caption-attachment-89105" style="width: 900px" class="wp-caption alignnone"><img class="size-full wp-image-89105" title="visa application" src="https://www.financialwatchngr.com/wp-content/uploads/2019/07/visa-application.jpg" alt="visa application" width="900" height="600" srcset="https://www.financialwatchngr.com/wp-content/uploads/2019/07/visa-application.jpg 900w, https://www.financialwatchngr.com/wp-content/uploads/2019/07/visa-application-230x153.jpg 230w, https://www.financialwatchngr.com/wp-content/uploads/2019/07/visa-application-525x350.jpg 525w" sizes="(max-width: 900px) 100vw, 900px" /><figcaption id="caption-attachment-89105" class="wp-caption-text">visa application</figcaption></figure>
<p><strong>Please note this process is applicable to Nigerian passport holders. Travelstart does not provide advice or assist with processing visas. The content of this article is listed as recommended by research and the Canadian embassy. Kindly check the embassy’s website BEFORE applying for your visa.</strong></p>
<h2>Types of Canadian visas</h2>
<p>There are several types of visas for Canada: Visitor Visa (Temporary Resident Visa), <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">Student Visa</a>, and <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">Work Visa</a>.</p>
<h3>Validity</h3>
<p>A <strong>Visitor Visa</strong> (Temporary Resident Visa) may be a multiple or single entry. A multiple-entry visa will allow you to stay in Canada for six months at a time and can be valid for up to 10 years.</p><div class="cBJ7dbLb" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- responsdisplay -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4174590025316317"
data-ad-slot="6123168580"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>A <strong>single-entry visa</strong> allows you to visit Canada once and is valid for up to six months from your date of arrival. For single entry visas, your passport should be valid for at least six months beyond your date of return to Nigeria.</p>
<p>The processing time for visas can take up to 30 days depending on the type of application submitted, the volume of applications received, and whether the application is complete. Your passport and visa can be collected from the Visa Application Centre you applied at or delivered via courier service.</p>
<p><img class="alignnone size-full wp-image-40689" src="https://www.travelstart.com.ng/blog/wp-content/uploads/2017/12/canadian-visa.jpg" alt="canadian visa" width="800" height="600" /></p>
<h2>Canadian Visa Fees</h2>
<p>The visa fees for a Visitor Visa may vary depending on if you pay online or in person at a visa application centre. They <strong><u>should be paid in naira</u></strong> and are subject to change whenever the embassy deems it fit. But generally, there are two types of fees: an application processing fee and a biometric fee.</p>
<p>Estimated fees when paying online and applying in person:</p>
<ul>
<li>Processing fee – about ₦28,000 (about $77)</li>
<li>Biometrics (per person) – about ₦24,000 (about $66)</li>
</ul>
<p>Estimated fees when applying through the VFS Global Visa Application Centre:</p>
<ul>
<li>Processing fee – about ₦28,000 (about $77)</li>
<li>Biometrics (per person) – about ₦24,000 (about $66)</li>
<li>Service charge – about ₦17,000 (about $47)</li>
</ul>
<h2>Canadian Visa Requirements</h2>
<ul>
<li>Completed Visitor Visa (IMM 5257) and Family Information (IMM 5645) forms.</li>
<li>An original and copy of your Nigerian passport. The passport will need to be valid for at least six months beyond your date of return and have at least two blank pages.</li>
<li>Two colour photographs that meet the <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">visa photo requirements</a>.</li>
<li>Proof of application processing fee and, if applicable, biometric fee.</li>
<li>Proof of sufficient funds for the duration of the trip (i.e. three months bank statements, payslips, proof of investments etc.).</li>
<li>If you are <strong><u>not</u></strong> paying for the trip you will need a letter from the person or institution sponsoring your trip and additional documents (i.e. a copy of their passport and a bank statement proving they have sufficient funds).</li>
<li>Proof of ties to Nigeria (i.e. employment letter, proof of businesses or assets etc.).</li>
<li>Copy of provisional flight booking and travel itinerary (i.e. accommodation reservations).</li>
<li>You may need to provide a medical history or proof of good health.</li>
<li>Previous passports showing travel history.</li>
<li>Additional documents to support your application (i.e. marriage certificates, invitation letters etc.).</li>
<li>A self-addressed return courier envelope.</li>
<li>Minors (under 18) travelling alone will need a letter of authorisation signed by both parents or legal guardians. For minors travelling with one parent, a letter of authorisation from the non-accompanying parent or legal guardian is required.</li>
<li>If you are visiting family or travelling for business you will need an invitation letter detailing the nature of the visit, length of stay, details of the host person or business etc.</li>
</ul>
<p><em>NOTE: Paper photographs are not required if you need to supply biometrics.</em></p>
<p>Detailed <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">document checklist for Visitor Visa</a>.</p>
<p>Documents may vary if you are applying through <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">VFS Global</a>.</p>
<p><img class="alignnone size-full wp-image-40690" src="https://www.travelstart.com.ng/blog/wp-content/uploads/2017/12/canadian-visa-nigeria.jpg" alt="canada visa requirements" width="800" height="600" /></p>
<h2>Where to apply</h2>
<p>There are two options when applying for a Canadian visitor visa: online or through a VFS Global Visa Application Centre. The visa process can take some time, so using a visa application centre is recommended if you have the option.</p>
<p><strong>Online</strong></p>
<p>To apply online you will need to have access to a scanner to create digital copies of your documents and a credit card to pay the processing and biometric fees.</p>
<p>Online applications can be done through the <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">IRCC website</a>.</p>
<p><strong>Canadian Embassy in Nigeria</strong></p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">4 Anifowoshe Street,Victoria Island, Lagos</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 1 271 5650</td>
</tr>
<tr>
<td width="103"><strong>Hours:</strong></td>
<td width="417">Monday to Thursday 7:30 AM – 4 PMFriday 7:30 AM – 1 PM</td>
</tr>
</tbody>
</table>
<p><strong>Canadian Visa Application Centre in Abuja</strong></p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Silverbird Entertainment Centre, Plot 1161, Memorial Drive,Central Business District, Abuja</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 815 019 9900</td>
</tr>
<tr>
<td width="103"><strong>Hours:</strong></td>
<td width="417">Monday to Friday 8 AM – 3 PM</td>
</tr>
</tbody>
</table>
<p><strong> Canadian Visa Application Centre in Lagos</strong></p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Manor Hall, Plot 110, Admiral Ayinla Way,Third Roundabout, Lekki Phase I – Lagos</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 815 019 9900</td>
</tr>
<tr>
<td width="103"><strong>Hours:</strong></td>
<td width="417">Monday to Friday 8 AM – 3 PM</td>
</tr>
</tbody>
</table>
<p><strong>Getting there and parking options</strong><br />
Parking is available at the Canadian Visa Application Centre in Abuja and Lagos. Parking at the VFS Global office in Lagos is limited. Buses and taxis are available to get you to the visa application centre.</p>
<p><strong>Courier service</strong></p>
<p>Once your passport and visa (if applicable) are ready for collection you have the option of collecting it from the Visa Application Centre or having it couriered to your chosen address. The courier service will be paid for when you submit your application.</p>
<p>This return courier service costs about ₦8,060 (about $23).</p>
<p>When collecting your passport in person, you will need the following documents:</p>
<ul>
<li>The application checklist provided to you by VFS Global when you submitted your application.</li>
<li>Your original identity card or other official proof of identification.</li>
<li>A copy of your photographic ID.</li>
</ul>
<p><img class="alignnone size-full wp-image-40693" src="https://www.travelstart.com.ng/blog/wp-content/uploads/2017/12/canada-visa-fees.jpg" alt="canada visa cost" width="800" height="600" /></p>
<h3>How to apply for a Canadian visa online?</h3>
<p>Whether you are applying online through the IRCC online application system or in-person through a visa application centre you will need to follow these steps:</p>
<ol>
<li>Download the <a href="http://www.cic.gc.ca/english/pdf/kits/forms/IMM5484E.pdf" target="_blank" rel="noopener noreferrer">Document Checklist</a>, <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">Visitor Visa (IMM 5257)</a>, and <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">Family Information (IMM 5645)</a> forms.</li>
<li>Fill out the application forms and gather all your supporting documents (as listed above).</li>
<li>If applicable, complete the <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">VFS consent form</a>. When using a third-party provider such as VFS Global you will need to submit a consent form along with your application or your application will be returned to you.</li>
<li>Pay the visa fees.</li>
<li>Submit your application to your local Visa Application Centre. Be sure to bring along all the documents stated in the document checklist and an accepted form of payment (cash is recommended).</li>
<li>Pay the service charge and obtain a receipt with a unique tracking number which you can use to track the progress of your application online.</li>
</ol>
<p><em>Note: If you are unable to provide all the supporting documents, you will need to complete a <a href="https://recruitmentportalngr.com/tag/visa-application/" target="_blank" rel="noopener noreferrer">waiver form</a></em> <em>and attach it to your application, or you risk being denied your visa.</em></p>
<p><img class="alignnone size-full wp-image-40691" src="https://www.travelstart.com.ng/blog/wp-content/uploads/2017/12/apply-canada-visa.jpg" alt="apply canada visa" width="800" height="600" /></p>
<h2>Printing and photographs</h2>
<p>Photocopy and photography services are available at the VFS Global application centres for an additional fee:</p>
<ul>
<li>Photocopy Services (per page) — about ₦40 (about $0.10)</li>
<li>Photography Services (per applicant) — about ₦2,340 (about $6.50)</li>
</ul>
<p>You can also get all the required documents and photographs for your Canadian Visitor Visa printed at the following places:</p>
<p><strong>Lagos</strong></p>
<p>Kodak Express</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Palms Shopping Mall, 1 Bisway Street,Maroko, Lagos</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 803 473 3069</td>
</tr>
</tbody>
</table>
<p>Exact Office Nigeria</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">1 Balogun Street, Off Awolowo Avenue,Ikeja, Lagos</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 815 814 7738</td>
</tr>
</tbody>
</table>
<p><strong>Abuja</strong></p>
<p><strong> </strong>Fotogold Studio Limited</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Plot 10, Lagos Crescent,Garki, Abuja</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 803 705 3201</td>
</tr>
</tbody>
</table>
<p>Photo Works Lab</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Suite C86, Murg Shopping Mall, Akwa Street,Area 10, Garki, Abuja</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 809 812 9319</td>
</tr>
</tbody>
</table>
<p>Clin Cyber Cafe &amp; Business Center</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">Suite CDS2, Ground Floor, 354 Mike Akhigbe Way,Jabi, Abuja</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 703 196 2009</td>
</tr>
</tbody>
</table>
<p>Cyber Café</p>
<table width="521">
<tbody>
<tr>
<td width="103"><strong>Address:</strong></td>
<td width="417">78 Abidjan Street &amp; Off Herbert Marcaulay Way,Zone 3, Wuse, Abuja</td>
</tr>
<tr>
<td width="103"><strong>Telephone:</strong></td>
<td width="417">(234) 803 597 5901</td>
</tr>
</tbody>
</table>
</p>	</div><div id="text-52" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><p>Do you need high paying jobs in Nigeria? If yes <span style="color: #ff0000;"><a style="color: #ff0000;" href="https://recruitmentportalngr.com/how-to-submit-your-cv-for-employment-on-recruitment-portal/"><strong>Submit your CV here</strong></a></span> and stand a chance of landing your dream job!</p>
</div>
</div><div id="text-51" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- resp ads for 2020 --><br />
<ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-4174590025316317" data-ad-slot="3733736777" data-ad-format="auto" data-full-width-responsive="true"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div></article><div class="mh-author-box clearfix">
<figure class="mh-author-box-avatar">
<img alt='' src='https://secure.gravatar.com/avatar/3d81b142ed182878d64d4c0d40f34d2a?s=125&#038;r=g' srcset='https://secure.gravatar.com/avatar/3d81b142ed182878d64d4c0d40f34d2a?s=250&#038;r=g 2x' class='avatar avatar-125 photo' height='125' width='125' />	</figure>
<div class="mh-author-box-header">
<span class="mh-author-box-name">
About Haruna Magaji		</span>
<span class="mh-author-box-postcount">
<a href="https://www.financialwatchngr.com/author/max24/" title="More articles written by Haruna Magaji'">
2482 Articles				</a>
</span>
</div>
<div class="mh-author-box-bio">
Haruna  Magaji is a journalist, foreign policy expert and closet musician. He is a graduate of ABU Zaria and a member of the Nigerian union of journalists. JSA, as he is fondly called, resides in Suleja, Abuja. email him at - <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="bcd4ddcec9d2ddd1dddbddd6d5fcdad5d2ddd2dfd5ddd0cbddc8dfd4d2dbce92dfd3d1">[email&#160;protected]</a>		</div>
<div class="mh-author-box-contact">
<a class="mh-author-box-facebook" href="https://web.facebook.com/" title="Follow Haruna Magaji on Facebook" target="_blank">
<i class="fa fa-facebook"></i>
<span class="screen-reader-text">Facebook</span>
</a>
</div></div><div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/05/how-to-apply-for-a-canadian-visa-from-nigeria-in-2020-www-cic-gc-ca/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.financialwatchngr.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1243' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><!-- Anti-spam plugin wordpress.org/plugins/anti-spam/ --><div class="wantispam-required-fields"><input type="hidden" name="wantispam_t" class="wantispam-control wantispam-control-t" value="1583414158" /><div class="wantispam-group wantispam-group-q" style="clear: both;">
<label>Current <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="afd6caefdd">[email&#160;protected]</a> <span class="required">*</span></label>
<input type="hidden" name="wantispam_a" class="wantispam-control wantispam-control-a" value="2020" />
<input type="text" name="wantispam_q" class="wantispam-control wantispam-control-q" value="6.5.4" autocomplete="off" />
</div>
<div class="wantispam-group wantispam-group-e" style="display: none;">
<label>Leave this field empty</label>
<input type="text" name="wantispam_e_email_url_website" class="wantispam-control wantispam-control-e" value="" autocomplete="off" />
</div>
</div><!--\End Anti-spam plugin --></form>	</div><!-- #respond -->
</div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="mh_magazine_custom_posts-50" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/" class="mh-widget-title-link">Price Watch</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-79046 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/03/03/current-prices-of-tokunbo-cars-in-nigeria-2020/" title="Current Prices of Tokunbo Cars in Nigeria (2020)"><img width="80" height="45" src="https://www.financialwatchngr.com/wp-content/uploads/2015/10/FLEET-OF-CARS.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="FLEET OF CARS" srcset="https://www.financialwatchngr.com/wp-content/uploads/2015/10/FLEET-OF-CARS.png 620w, https://www.financialwatchngr.com/wp-content/uploads/2015/10/FLEET-OF-CARS-300x169.png 300w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/03/03/current-prices-of-tokunbo-cars-in-nigeria-2020/" title="Current Prices of Tokunbo Cars in Nigeria (2020)">
Current Prices of Tokunbo Cars in Nigeria (2020)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/03/">March 3, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-78979 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/03/02/current-price-of-dangote-cement-today-2020/" title="Current price of Dangote Cement Today (2020)"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Current-price-of-Dangote-Cement-Today4-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Current price of Dangote Cement Today" srcset="https://www.financialwatchngr.com/wp-content/uploads/2019/05/Current-price-of-Dangote-Cement-Today4-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2019/05/Current-price-of-Dangote-Cement-Today4-678x509.jpg 678w, https://www.financialwatchngr.com/wp-content/uploads/2019/05/Current-price-of-Dangote-Cement-Today4-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/03/02/current-price-of-dangote-cement-today-2020/" title="Current price of Dangote Cement Today (2020)">
Current price of Dangote Cement Today (2020)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/03/">March 2, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-90515 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/03/02/various-types-of-roofing-sheets-in-nigeria-current-prices-2020/" title="Various types of Roofing Sheets in Nigeria &#038; current Prices (2020)"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2020/03/Various-types-of-Roofing-Sheets-in-Nigeria-current-Prices6-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Various types of Roofing Sheets in Nigeria current Prices" srcset="https://www.financialwatchngr.com/wp-content/uploads/2020/03/Various-types-of-Roofing-Sheets-in-Nigeria-current-Prices6-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2020/03/Various-types-of-Roofing-Sheets-in-Nigeria-current-Prices6-678x509.jpg 678w, https://www.financialwatchngr.com/wp-content/uploads/2020/03/Various-types-of-Roofing-Sheets-in-Nigeria-current-Prices6-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/03/02/various-types-of-roofing-sheets-in-nigeria-current-prices-2020/" title="Various types of Roofing Sheets in Nigeria &#038; current Prices (2020)">
Various types of Roofing Sheets in Nigeria &#038; current Prices (2020)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/03/">March 2, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88789 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-4k-tv-in-nigeria-updated-2020-prices/" title="Current prices of 4K TV in Nigeria – updated 2020 prices"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-4K-TV-in-Nigeria-–-updated-2020-prices4-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Current prices of K TV in Nigeria – updated prices" srcset="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-4K-TV-in-Nigeria-–-updated-2020-prices4-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-4K-TV-in-Nigeria-–-updated-2020-prices4-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-4k-tv-in-nigeria-updated-2020-prices/" title="Current prices of 4K TV in Nigeria – updated 2020 prices">
Current prices of 4K TV in Nigeria – updated 2020 prices									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 16, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88783 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-android-tv-box-in-nigeria-updated-2020-prices/" title="Current prices of Android TV Box in Nigeria  &#8211; updated 2020 prices"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Android-TV-Box-in-Nigeria-updated-2020-prices-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Current prices of Android TV Box in Nigeria updated prices" srcset="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Android-TV-Box-in-Nigeria-updated-2020-prices-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Android-TV-Box-in-Nigeria-updated-2020-prices-678x509.jpg 678w, https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Android-TV-Box-in-Nigeria-updated-2020-prices-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-android-tv-box-in-nigeria-updated-2020-prices/" title="Current prices of Android TV Box in Nigeria  &#8211; updated 2020 prices">
Current prices of Android TV Box in Nigeria  &#8211; updated 2020 prices									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 16, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88777 post type-post status-publish format-standard has-post-thumbnail category-prices-of-goods-in-nigeria">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-skyworth-tv-in-nigeria-updated-2020-prices/" title="Current prices of Skyworth TV in Nigeria – updated 2020 prices"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Skyworth-in-Nigeria-–-updated-2020-prices4-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Current prices of Skyworth in Nigeria – updated prices" srcset="https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Skyworth-in-Nigeria-–-updated-2020-prices4-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2020/01/Current-prices-of-Skyworth-in-Nigeria-–-updated-2020-prices4-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/16/current-prices-of-skyworth-tv-in-nigeria-updated-2020-prices/" title="Current prices of Skyworth TV in Nigeria – updated 2020 prices">
Current prices of Skyworth TV in Nigeria – updated 2020 prices									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 16, 2020</a></span>
</div>
</div>
</li>			</ul></div><div id="text-48" class="mh-widget widget_text">			<div class="textwidget"><p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- 300x600 display --><br />
<ins class="adsbygoogle"
style="display:inline-block;width:300px;height:600px"
data-ad-client="ca-pub-4174590025316317"
data-ad-slot="3431549877"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
</div><div id="mh_magazine_custom_posts-51" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://www.financialwatchngr.com/category/job-past-questions/" class="mh-widget-title-link">Job Past Questions</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-48554 post type-post status-publish format-standard has-post-thumbnail category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/21/kpmg-recruitment-past-questions-answers-pdf-free-download/" title="KPMG Recruitment Past Questions And Answers PDF free Download"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2017/11/KPMG2-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="KPMG" srcset="https://www.financialwatchngr.com/wp-content/uploads/2017/11/KPMG2-80x60.jpg 80w, https://www.financialwatchngr.com/wp-content/uploads/2017/11/KPMG2-678x509.jpg 678w, https://www.financialwatchngr.com/wp-content/uploads/2017/11/KPMG2-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/21/kpmg-recruitment-past-questions-answers-pdf-free-download/" title="KPMG Recruitment Past Questions And Answers PDF free Download">
KPMG Recruitment Past Questions And Answers PDF free Download									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 21, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-81985 post type-post status-publish format-standard has-post-thumbnail category-careers category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/13/nigerian-customs-service-past-questions-answers-pdf-download/" title="Nigerian Customs Service past Questions &#038; Answers (PDF Download)"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2019/04/Nigerian-Customs-Service-past-Questions-Answers-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Nigerian Customs Service past Questions Answers" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/13/nigerian-customs-service-past-questions-answers-pdf-download/" title="Nigerian Customs Service past Questions &#038; Answers (PDF Download)">
Nigerian Customs Service past Questions &#038; Answers (PDF Download)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76516 post type-post status-publish format-standard has-post-thumbnail category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2020/01/10/fcmb-aptitude-test-past-questions-answers-pdf-download/" title="FCMB aptitude test past Questions &#038; Answers (PDF Download)"><img width="42" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2018/12/FCMB-PAST-QUESTIONS.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="FCMB PAST QUESTIONS" srcset="https://www.financialwatchngr.com/wp-content/uploads/2018/12/FCMB-PAST-QUESTIONS.png 260w, https://www.financialwatchngr.com/wp-content/uploads/2018/12/FCMB-PAST-QUESTIONS-161x230.png 161w, https://www.financialwatchngr.com/wp-content/uploads/2018/12/FCMB-PAST-QUESTIONS-245x350.png 245w" sizes="(max-width: 42px) 100vw, 42px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2020/01/10/fcmb-aptitude-test-past-questions-answers-pdf-download/" title="FCMB aptitude test past Questions &#038; Answers (PDF Download)">
FCMB aptitude test past Questions &#038; Answers (PDF Download)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2020/01/">January 10, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-231 post type-post status-publish format-standard has-post-thumbnail category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2019/12/23/sss-recruitment-2018-download-state-security-service-sss-past-question-answers/" title="SSS Recruitment 2018: Download State Security Service (SSS) Past question /Answers"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2016/10/DSS-operatives-invade-judges-houses-in-Abuja-arrest-one-Punch-Newspapers-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="armed mobile police storm Melaye’s Abuja residence" srcset="https://www.financialwatchngr.com/wp-content/uploads/2016/10/DSS-operatives-invade-judges-houses-in-Abuja-arrest-one-Punch-Newspapers-80x60.png 80w, https://www.financialwatchngr.com/wp-content/uploads/2016/10/DSS-operatives-invade-judges-houses-in-Abuja-arrest-one-Punch-Newspapers-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2019/12/23/sss-recruitment-2018-download-state-security-service-sss-past-question-answers/" title="SSS Recruitment 2018: Download State Security Service (SSS) Past question /Answers">
SSS Recruitment 2018: Download State Security Service (SSS) Past question /Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2019/12/">December 23, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86612 post type-post status-publish format-standard has-post-thumbnail category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2019/12/13/ndlea-recruitment-past-questions-answers-pdf-download/" title="NDLEA recruitment Past Questions &#038; Answers (PDF Download)"><img width="80" height="60" src="https://www.financialwatchngr.com/wp-content/uploads/2019/08/ndlea-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ndlea" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2019/12/13/ndlea-recruitment-past-questions-answers-pdf-download/" title="NDLEA recruitment Past Questions &#038; Answers (PDF Download)">
NDLEA recruitment Past Questions &#038; Answers (PDF Download)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2019/12/">December 13, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76391 post type-post status-publish format-standard has-post-thumbnail category-job-past-questions">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://www.financialwatchngr.com/2019/10/16/civil-service-commission-recruitment-past-questions-and-answers-pdf-download/" title="Civil Service Commission Recruitment Past Questions And Answers PDF Download"><img width="80" height="55" src="https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Civil Service Commission Recruitment Past Questions And Answers PDF Download" srcset="https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1.png 597w, https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1-230x159.png 230w, https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1-506x350.png 506w, https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1-100x70.png 100w, https://www.financialwatchngr.com/wp-content/uploads/2017/12/fcsc3-1-218x150.png 218w" sizes="(max-width: 80px) 100vw, 80px" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://www.financialwatchngr.com/2019/10/16/civil-service-commission-recruitment-past-questions-and-answers-pdf-download/" title="Civil Service Commission Recruitment Past Questions And Answers PDF Download">
Civil Service Commission Recruitment Past Questions And Answers PDF Download									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2019/10/">October 16, 2019</a></span>
</div>
</div>
</li>			</ul></div>	</aside>	</div>
</div>
	<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-2403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2403"><a href="https://www.financialwatchngr.com/about/">About</a></li>
<li id="menu-item-2402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2402"><a href="https://www.financialwatchngr.com/contact/">Contact</a></li>
<li id="menu-item-84189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84189"><a href="https://www.financialwatchngr.com/authors-and-contributors/">Team</a></li>
<li id="menu-item-61817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-61817"><a href="https://www.financialwatchngr.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-87681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87681"><a href="https://www.financialwatchngr.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-87682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87682"><a href="https://www.financialwatchngr.com/feedback/">Feedback</a></li>
<li id="menu-item-90439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90439"><a href="https://www.financialwatchngr.com/advertise-usd-rate/">ADVERTISE – USD RATE</a></li>
<li id="menu-item-90440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90440"><a href="https://www.financialwatchngr.com/advertise/">ADVERTISE – NAIRA RATE</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright © 2019 | <a href="https://www.financialwatchngr.com">FINANCIAL WATCH</a> 		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-110378536-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-110378536-1');
</script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-content/plugins/anti-spam/assets/js/anti-spam.js?ver=6.5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.financialwatchngr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://www.financialwatchngr.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>
</body>
</html><!-- WP Fastest Cache file was created in 0.62751984596252 seconds, on 05-03-20 14:15:58 -->