<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
	<meta name="facebook-domain-verification" content="7h6xpad7df6nurq950tw7mnr9kqkn3" />
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WT8Q8C9');</script>
<!-- End Google Tag Manager -->
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.6.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>All you need to know about EFCC Recruitment 2021/2022 Form portal &raquo; Financial Watch</title>
	<meta name="description" content="All you need to know about EFCC Recruitment 2020/2021 Form portal – Efccnigeria.org/efcc/career registration guide - Have you been looking" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="All you need to know about EFCC Recruitment 2021/2022 Form portal &raquo; Financial Watch" />
	<meta property="og:description" content="All you need to know about EFCC Recruitment 2020/2021 Form portal – Efccnigeria.org/efcc/career registration guide - Have you been looking" />
	<meta property="og:url" content="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/" />
	<meta property="og:site_name" content="Financial Watch" />
	<meta property="article:publisher" content="https://web.facebook.com/FinancialWatchNigeria/" />
	<meta property="article:published_time" content="2021-01-22T07:35:23+00:00" />
	<meta property="article:modified_time" content="2021-01-22T07:38:14+00:00" />
	<meta property="og:image" content="https://www.financialwatchngr.com/wp-content/uploads/2019/12/efcc-recruitment-20204.jpg" />
	<meta property="og:image:width" content="509" />
	<meta property="og:image:height" content="509" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@financialwatchn" />
	<meta name="twitter:site" content="@financialwatchn" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Tosan Olajide">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<meta name="geo.placename" content="Festac, Lagos" />
	<meta name="geo.region" content="Nigeria" />
	<!-- / Yoast SEO Premium plugin. -->


<link rel="amphtml" href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/amp/" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//856082.smushcdn.com' />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; Feed" href="https://www.financialwatchngr.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; Comments Feed" href="https://www.financialwatchngr.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Financial Watch &raquo; All you need to know about EFCC Recruitment 2021/2022 Form portal Comments Feed" href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://hb.wpmucdn.com/www.financialwatchngr.com/488bd5fa-5b69-4c57-a6c6-bcf9d6f7a5c8.css' type='text/css' media='all' />
<link rel='stylesheet' id='wphb-1-css'  href='https://hb.wpmucdn.com/www.financialwatchngr.com/6a44beca-f949-44f5-a373-2f0ebfe26faa.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://hb.wpmucdn.com/www.financialwatchngr.com/5191c9a4-02c2-4137-b248-75e640ff59af.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://hb.wpmucdn.com/www.financialwatchngr.com/8a467ee4-000f-4f91-a5e6-6370592c20c8.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%7cOpen+Sans' type='text/css' media='all' />
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/8764e48d-44e0-4a69-8397-d7e9dcce7d10.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/0c71d74e-d96d-4b15-a409-a7d365152015.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.financialwatchngr.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.financialwatchngr.com/wp-json/wp/v2/posts/88145" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.financialwatchngr.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.financialwatchngr.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://www.financialwatchngr.com/?p=88145' />
<link rel="alternate" type="application/json+oembed" href="https://www.financialwatchngr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.financialwatchngr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F&#038;format=xml" />
<script data-ad-client="ca-pub-4174590025316317" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><meta name="google-site-verification" content="oOQR81Es3VTwmx8bdp6EEOCq6aQJ9tybanSWODii0uM" />


<meta name="msvalidate.01" content="B7898B7005E5E6C97EF3453297089F48" />






		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload { opacity: 0; }
				.lazyloading {
					border: 0 !important;
					opacity: 1;
					background: #F3F3F3 url('https://www.financialwatchngr.com/wp-content/plugins/wp-smush-pro/app/assets/images/smush-placeholder.png') no-repeat center !important;
					background-size: 16px auto !important;
					min-width: 16px;
				}
					</style>
		<style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #6b6b6b; }
.mh-extra-nav-bg { background: rgba(107, 107, 107, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #6b6b6b; background: rgba(107, 107, 107, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(107, 107, 107, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #6b6b6b; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #5b5b5b; background: rgba(91, 91, 91, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #5b5b5b; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #5b5b5b; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #5b5b5b; }
.mh-subheader, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget .search-form, .mh-tab-button, .mh-tab-content, .mh-nip-widget, .mh-magazine-facebook-page-widget, .mh-social-widget, .mh-posts-horizontal-widget, .mh-ad-spot, .mh-info-spot { background: #595959; }
.mh-tab-post-item { border-color: rgba(255, 255, 255, 0.3); }
.mh-tab-comment-excerpt { background: rgba(255, 255, 255, 0.6); }
.mh-header-nav-bottom li a, .mh-social-nav-bottom .fa-mh-social, .mh-boxed-layout .mh-ticker-item-bottom a, .mh-header-date-bottom, .page-numbers, a .pagelink, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout3 .mh-widget-title a, .mh-tabbed-widget, .mh-tabbed-widget a, .mh-posts-horizontal-title a { color: #fcfcfc; }
.entry-content a { color: #dd0000; }
a:hover, .entry-content a:hover, #respond a:hover, #respond #cancel-comment-reply-link:hover, #respond .logged-in-as a:hover, .mh-comment-list .comment-meta a:hover, .mh-ping-list .mh-ping-item a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #dd3333; }
</style>
<!--[if lt IE 9]>
<script src="https://www.financialwatchngr.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 15px; font-size: 0.9375rem; }
body { font-family: "Noto Sans", sans-serif; }
</style>
      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.financialwatchngr.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'f4ce5e76-1a00-43d3-8e7f-b222251af2cc';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.financialwatchngr.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['acceptButtonText'] = "Allow Alerts";
oneSignal_options['promptOptions']['cancelButtonText'] = "Not Now";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="icon" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-150x150-1.jpg" sizes="32x32" />
<link rel="icon" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-300x300-1.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-300x300-1.jpg" />
<meta name="msapplication-TileImage" content="https://www.financialwatchngr.com/wp-content/uploads/2016/08/cropped-FNW-ICON-google-300x300-1.jpg" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-88145 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="https://schema.org/WebPage">
	<!-- Google Tag Manager (noscript) -->
<noscript><iframe 
height="0" width="0" style="display:none;visibility:hidden" data-src="https://www.googletagmanager.com/ns.html?id=GTM-WT8Q8C9" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-top">
							January 22, 2021						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-top">
							<form role="search" method="get" class="search-form" action="https://www.financialwatchngr.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-1 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://www.financialwatchngr.com/" class="custom-logo-link" rel="home"><img width="200" height="60"   alt="cropped financialwatch" data-srcset="https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?size=135x41&amp;lossy=1&amp;strip=1&amp;webp=1 135w, https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?lossy=1&amp;strip=1&amp;webp=1 200w"  data-src="https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?lossy=1&strip=1&webp=1" data-sizes="(max-width: 200px) 100vw, 200px" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="200" height="60" src="https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?lossy=1&strip=1&webp=1" class="custom-logo" alt="cropped financialwatch" srcset="https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?size=135x41&amp;lossy=1&amp;strip=1&amp;webp=1 135w, https://856082.smushcdn.com/649939/wp-content/uploads/2020/01/cropped-financialwatch2020.png?lossy=1&amp;strip=1&amp;webp=1 200w" sizes="(max-width: 200px) 100vw, 200px" /></noscript></a></div>
</div>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-75935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-75935"><a href="https://www.financialwatchngr.com/">HOME</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.financialwatchngr.com/category/banking-news-in-nigeria/">Banking</a></li>
<li id="menu-item-79729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79729"><a href="https://www.financialwatchngr.com/category/economy/">ECONOMY</a></li>
<li id="menu-item-84856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84856"><a href="https://www.financialwatchngr.com/category/latest-news/">HEADLINES</a></li>
<li id="menu-item-79727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79727"><a href="https://www.financialwatchngr.com/category/view-point/">VIEW POINT</a></li>
<li id="menu-item-79933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79933"><a href="https://www.financialwatchngr.com/category/cryptocurrency/">Cryptocurrency</a></li>
<li id="menu-item-79935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79935"><a href="https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/">PRICE WATCH</a></li>
</ul></div>		</nav>
	</div>
			<div class="mh-extra-nav-wrap">
			<div class="mh-extra-nav-bg">
				<nav class="mh-navigation mh-extra-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
					<div class="menu-below-main-menu-container"><ul id="menu-below-main-menu" class="menu"><li id="menu-item-79929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79929"><a href="https://www.financialwatchngr.com/category/prices-of-goods-in-nigeria/">PRICE WATCH</a></li>
<li id="menu-item-79928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79928"><a href="https://www.financialwatchngr.com/category/job-past-questions/">Job Past Questions</a></li>
<li id="menu-item-79922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-79922"><a href="https://www.financialwatchngr.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-79930" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79930"><a href="https://www.financialwatchngr.com/category/careers/">Careers</a></li>
<li id="menu-item-79923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79923"><a href="https://www.financialwatchngr.com/disclaimer/">Disclaimer</a></li>
</ul></div>				</nav>
			</div>
		</div>
	</header>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.financialwatchngr.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://www.financialwatchngr.com/category/careers/" itemprop="item"><span itemprop="name">Careers</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>All you need to know about EFCC Recruitment 2021/2022 Form portal</nav>
<article id="post-88145" class="post-88145 post type-post status-publish format-standard has-post-thumbnail hentry category-careers">
	<header class="entry-header clearfix"><h1 class="entry-title">All you need to know about EFCC Recruitment 2021/2022 Form portal</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2021/01/">January 22, 2021</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.financialwatchngr.com/author/olajide/">Tosan Olajide</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.financialwatchngr.com/category/careers/" rel="category tag">Careers</a></span>
</div>
	</header>
	<div id="text-37" class="mh-widget mh-posts-1 widget_text">			<div class="textwidget"><p>Looking for job? your search ends here! Visit <a href="https://recruitmentportalngr.com/"><span style="color: #ff0000;"><strong>https://recruitmentportalngr.com/</strong></span> </a> to apply now OR Send us a <strong><span style="color: #ff0000;"><a style="color: #ff0000;" href="https://recruitmentportalngr.com/how-to-create-ads-submit-cvs-find-jobs-cvs-on-martify-com-ng/">WhatsApp Message here!</a></span></strong></p>
</div>
		</div><div id="text-45" class="mh-widget mh-posts-1 widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- resp ads for 2020 --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4174590025316317"
     data-ad-slot="3733736777"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div>	<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F&t=All+you+need+to+know+about+EFCC+Recruitment+2021%2F2022+Form+portal', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=All+you+need+to+know+about+EFCC+Recruitment+2021%2F2022+Form+portal:&url=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.financialwatchngr.com%2F2021%2F01%2F22%2Fall-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal%2F&media=https://www.financialwatchngr.com/wp-content/uploads/2019/12/efcc-recruitment-20204.jpg&description=All+you+need+to+know+about+EFCC+Recruitment+2021%2F2022+Form+portal', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="/cdn-cgi/l/email-protection#427d313720282721367f032e2e6770723b2d376770722c272726677072362d677072292c2d3567707223202d37366770720704010167707210272130372b362f272c366770727072707367700470727070677072042d302f677072322d3036232e64232f3279202d263b7f2a363632316771036770046770043535356c242b2c232c212b232e352336212a2c25306c212d2f6770047072707367700472736770047070677004232e2e6f3b2d376f2c2727266f362d6f292c2d356f23202d37366f272421216f30272130372b362f272c366f707270736f707270706f242d302f6f322d3036232e677004" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
<p><strong>All you need to know about EFCC Recruitment 2021/2022 Form portal – Efccnigeria.org/efcc/career registration guide &#8211; </strong>Have you been looking for <strong><em>EFCC Recruitment</em></strong> 2021/2022 Application Form? If you just answered yes, then I’ll be showing you –<a href="https://recruitmentportalngr.com/efcc-recruitment-2019-2020-form-is-right-here-efccnigeria-org-efcc-career-registration-guide/"> <strong><em>efccnigeria.org/efcc/career</em></strong></a> (Economic and Financial Crimes Commission) registration guide &#8211; <a href="https://recruitmentportalngr.com/efcc-recruitment-2019-2020-form-is-right-here-efccnigeria-org-efcc-career-registration-guide/">Apply here!</a></p>
<p><em>EFCC Recruitment 2021/2022 Form is Right Here – <a href="https://recruitmentportalngr.com/efcc-recruitment-2019-2020-form-is-right-here-efccnigeria-org-efcc-career-registration-guide/">efccnigeria.org/efcc/career</a> registration guide</em></p>
<p>I’ll like to encourage you to ca down and read this guide very well. You’ll learn the whole steps involved in submitting  online recruitment form at Economic and Financial Crimes Commission Portal.</p><div class="0evnpJUs" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- resp ads for 2020 -->
<ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-4174590025316317" data-ad-slot="3733736777" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>So are you truly willing to learn all the steps now? Do you want to know if department of petroleum resources recruitment form is on or not?</p>
<p>Are you interested in seeing all the guidelines about how to register for EFCC jobs here in Nigeria? If yes, read the guides below:</p>
<p>Please be careful of fraudsters. The EFCC does not recruit via any form of agents, contractors or consultants. All information regarding Economic and Financial Crimes Commission recruitment can be found on the EFCC website at <a href="https://recruitmentportalngr.com/efcc-recruitment-2019-2020-form-is-right-here-efccnigeria-org-efcc-career-registration-guide/">efccnigeria.org/efcc/career</a></p>
<p>EFCC recruitment 2021 requirements for graduate trainees</p>
<ul>
<li>Applicants must have a B.Sc. or B.A. or B.Pharm or HND in any relevant Engineering and Management or Social Sciences course with an at least a Second Class Lower or Upper Credit.</li>
<li>Applicants should have completed their NYSC with certificate or certificate of exemption.</li>
<li>They should not be more than thirty years old.</li>
<li>Must be computer literate.</li>
</ul>
<p>efcc recruitment</p>
<p>How to Apply for  Economic and Financial Crimes Commission recruitment 2021 Form?</p>
<ul>
<li>Applicants are to fill and submit their applications online via the Department of Petroleum Resources Application Portal.</li>
<li>Multiple <a href="https://recruitmentportalngr.com/efcc-recruitment-2019-2020-form-is-right-here-efccnigeria-org-efcc-career-registration-guide/">all applications</a> submitted by an applicant for more than one position will be disqualified.</li>
<li>To apply you need to register your account at  Economic and Financial Crimes Commission portal.</li>
</ul>
<p><strong>Warning!</strong></p>
<p><strong>Please note that EFCC 2021 recruitment form is not yet out. This post is for you to know the things needed for EFCC jobs. Don’t pay anyone any money for employment purposes. </strong></p>
<p><strong>Please note that EFCC Recruitment 2021 Form will be Free. if anyone ask you for money, kindly report such person to the appropriate law enforcement agencies. </strong></p>
<p>If you want latest news update concerning <strong><em>EFCC Recruitment 2021 (Economic and Financial Crimes Commission) </em></strong>form, kindly comment below now.</p>
	</div><div id="text-53" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- resp ads for 2020 --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4174590025316317"
     data-ad-slot="3733736777"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div><div id="text-52" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><p>Do you need high paying jobs in Nigeria? If yes <span style="color: #ff0000;"><a style="color: #ff0000;" href="https://recruitmentportalngr.com/how-to-submit-your-cv-for-employment-on-recruitment-portal/"><strong>Submit your CV here</strong></a></span> and stand a chance of landing your dream job!</p>
</div>
		</div></article><div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title">
				<span class="mh-widget-title-inner">
					3 Comments				</span>
			</h4>
			<ol class="commentlist mh-comment-list">
						<li id="comment-138870" class="comment even thread-even depth-1 entry-content">
			<article id="div-comment-138870" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt=''  data-srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/4fc/4fca53f20c291e7a76a0ef67325ae1b4x100.jpg 2x'  height='50' width='50' loading='lazy' data-src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/4fc/4fca53f20c291e7a76a0ef67325ae1b4x50.jpg?lossy=1&strip=1&webp=1' class='avatar avatar-50 photo lazyload' src='data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==' /><noscript><img alt='' src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/4fc/4fca53f20c291e7a76a0ef67325ae1b4x50.jpg?lossy=1&strip=1&webp=1' srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/4fc/4fca53f20c291e7a76a0ef67325ae1b4x100.jpg 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/></noscript>						<b class="fn">Muhammad Auwal Muhammad</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/#comment-138870"><time datetime="2020-09-28T08:17:58+01:00">September 28, 2020 at 8:17 AM</time></a>					</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p><a href="/cdn-cgi/l/email-protection#89e4fce1e8e4e4e8ede8fcfee8e5e4fce1e8e4e4e8edbabec9eee4e8e0e5a7eae6e4"><span class="__cf_email__" data-cfemail="5c3129343d31313d383d292b3d303129343d31313d386f6b1c3b313d3530723f3331">[email&#160;protected]</span></a></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-138870' data-commentid="138870" data-postid="88145" data-belowelement="div-comment-138870" data-respondelement="respond" data-replyto="Reply to Muhammad Auwal Muhammad" aria-label='Reply to Muhammad Auwal Muhammad'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-125338" class="comment odd alt thread-odd thread-alt depth-1 entry-content">
			<article id="div-comment-125338" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt=''  data-srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/c7c/c7c4333ad451698bb49099db12fd6291x100.jpg 2x'  height='50' width='50' loading='lazy' data-src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/c7c/c7c4333ad451698bb49099db12fd6291x50.jpg?lossy=1&strip=1&webp=1' class='avatar avatar-50 photo lazyload' src='data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==' /><noscript><img alt='' src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/c7c/c7c4333ad451698bb49099db12fd6291x50.jpg?lossy=1&strip=1&webp=1' srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/c7c/c7c4333ad451698bb49099db12fd6291x100.jpg 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/></noscript>						<b class="fn">FUMI BLESSING</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/#comment-125338"><time datetime="2020-05-06T07:39:55+01:00">May 6, 2020 at 7:39 AM</time></a>					</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>HELLO, GOOD DAY SIR/MA</p>
<p>HAVE YOU HELD ABOUT LAVITA TRUST INVESTMENT…?</p>
<p>LAVITA TRUST INVESTMENT is a matrix system which give you DOUBLE of your CAPITAL back in ( 45 Minutes ) after Registrations</p>
<p>LAVITA PACKAGES<br />
N20,000——N40,000<br />
N40,000——N80,000<br />
N50,000——N100,000<br />
N100,000—–N200,000<br />
N150,000—–N350,000<br />
N300,000—–N600,000<br />
N200,000—–N400,000<br />
N400,000—–N800,000<br />
N500,000—–N1,000,000</p>
<p>NOTE: we credit your account after 45mins of Your Registeration<br />
INTRODUCTION<br />
LAVITA TRUST Investment is a company duely registered under the Coporate Affairs Commission of Nigeria and certified fraud free to do business in Nigeria by the Economic Financial Crimes Commission (EFCC). This is a Nigerian network marketing company founded by Ifeanyi Alex Monye with it’s Head Quarter’s. The company takes pride in the fact that it stands out amongst other network marketing companies. It has the best compensation plan, affordable and effective services, systems that keeps her customers coming back for more. When you join this company, you get more than their outstanding services.</p>
<p>09068834101</p>
<p>ITS SIMPLE HERE!!!!!!!<br />
We trade with hard currency here like bit coin we make 3tripple of your donation and send you you two part and we benefit one part Example if you invest with 100k within 25mins we make profit of 300k then send 200k to you then profit 100k This is not mmm where they merge people to donate for each other<br />
You pay directly to us and we credit you directly</p>
<p>Contact Mrs. FUMI BLESSING<br />
09068834101 </p>
<p>NOTE:- YOU GET CREDITED BACK IN LESS THAN 45 MINUTES.</p>
<p>CHAT US-UP IF INTEREST FILL YOUR FORM AND START EARNING</p>
<p>NOTE: You can finish reading this and decide not to take the necessary actions, but the next time you want to complain about not having money, just know that you are on your own problem.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-125338' data-commentid="125338" data-postid="88145" data-belowelement="div-comment-125338" data-respondelement="respond" data-replyto="Reply to FUMI BLESSING" aria-label='Reply to FUMI BLESSING'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-125264" class="comment even thread-even depth-1 entry-content">
			<article id="div-comment-125264" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt=''  data-srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/d66/d66a25436b1ed9f701e8a64c1e5b1069x100.jpg 2x'  height='50' width='50' loading='lazy' data-src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/d66/d66a25436b1ed9f701e8a64c1e5b1069x50.jpg?lossy=1&strip=1&webp=1' class='avatar avatar-50 photo lazyload' src='data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==' /><noscript><img alt='' src='https://856082.smushcdn.com/649939/wp-content/wphb-cache/gravatar/d66/d66a25436b1ed9f701e8a64c1e5b1069x50.jpg?lossy=1&strip=1&webp=1' srcset='https://www.financialwatchngr.com/wp-content/wphb-cache/gravatar/d66/d66a25436b1ed9f701e8a64c1e5b1069x100.jpg 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/></noscript>						<b class="fn">Elizabeth Tina</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.financialwatchngr.com/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/#comment-125264"><time datetime="2020-05-05T21:19:15+01:00">May 5, 2020 at 9:19 PM</time></a>					</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>*GOOD DAY MA/SIR*</p>
<p>Have you had about *LAVITA RICCA INVESTMENT* ? am not talking about MMM or Ponzi SCHEME<br />
lavita is a matrix system which give you DOUBLE of your CAPITAL back in (45 min) after registration</p>
<p>LAVITA PACKAGES</p>
<p>₦10,000——–₦20,000❌❌❌<br />
₦20,000——–₦40,000<br />
₦40,000——–₦80,000<br />
₦50,000——–₦100,000<br />
₦100,000——₦200,000<br />
₦200,000——₦400,000<br />
₦400,000——₦800,000<br />
₦800,000——₦1,600,000<br />
₦1,000,000—₦2,000,000</p>
<p>NOTE: we credit your account after 45min after registeration.</p>
<p>INTRODUCTION<br />
Lavita Ricca International is a company duely registered under the Coporate Affairs Commission of Nigeria and certified fraud free to do business in Nigeria by the Economic Financial Crimes Commission (EFCC). This is a Nigerian network marketing company founded by Mr. Ifeanyi Alex Monye with it’s Head Quarter’s. The company takes pride in the fact that it stands out amongst other network marketing companies. It has the best compensation plan, affordable and effective services, systems that keeps her customers coming back for more. When you join this company, you get more than their outstanding services.</p>
<p>CONTACT NAME:- ELIZABETH TINA</p>
<p>HOT LINE:+2349036369810</p>
<p>ITS SIMPLE HERE !!!!!!!<br />
We trade with hard currency here like bit coin we make 3tripple of your donation and send you you two part and we benefit one part Example if you invest with 20k within 45mins we make profit of 60k then send 40k to you then profit 20k. This is not mmm where they merge people to donate for each other<br />
You pay directly to us and we credit you directly.</p>
<p>+2349036369810</p>
<p>Note:you get credited in less than 45mins.</p>
<p>CHAT US-UP IF INTEREST FILL YOUR FORM AND START EARNING</p>
<p>NOTE: You can finish reading this and decide not to take the necessary actions, but the next time you want to complain about not having money, just know that you are on your own problem. ? ? ?</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-125264' data-commentid="125264" data-postid="88145" data-belowelement="div-comment-125264" data-respondelement="respond" data-replyto="Reply to Elizabeth Tina" aria-label='Reply to Elizabeth Tina'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
			</ol>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/01/22/all-you-need-to-know-about-efcc-recruitment-2021-2022-form-portal/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.financialwatchngr.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea autocomplete="new-password"  id="h6f8073388"  name="h6f8073388"   cols="45" rows="5" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a03282393c8ed18cb0adb07295dcfd14" );document.getElementById("h6f8073388").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='88145' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	</div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="mh_magazine_custom_posts-57" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Latest Headlines</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89124 post type-post status-publish format-standard has-post-thumbnail category-view-point tag-npower-news">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.financialwatchngr.com/2021/01/22/why-fg-should-consider-permanent-employment-for-npower-2016-beneficiaries/" title="Why FG should consider permanent employment for NPower 2016 beneficiaries">
										Why FG should consider permanent employment for NPower 2016 beneficiaries									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2021/01/">January 22, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88151 post type-post status-publish format-standard has-post-thumbnail category-careers">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.financialwatchngr.com/2021/01/22/dpr-recruitment-portal-2021-see-how-to-apply-requirements/" title="DPR recruitment portal 2021 &#8211; See how to apply &#038; requirements">
										DPR recruitment portal 2021 &#8211; See how to apply &#038; requirements									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2021/01/">January 22, 2021</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-90035 post type-post status-publish format-standard has-post-thumbnail category-careers">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.financialwatchngr.com/2021/01/22/nbti-recruitment-2021-application-form-portal-status-www-nbti-gov-ng/" title="NBTI Recruitment 2021 Application Form Portal status | www.nbti.gov.ng">
										NBTI Recruitment 2021 Application Form Portal status | www.nbti.gov.ng									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.financialwatchngr.com/2021/01/">January 22, 2021</a></span>
</div>
							</div>
						</li>			</ul></div>	</aside>	</div>
    </div>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-links-container"><ul id="menu-footer-links" class="menu"><li id="menu-item-2403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2403"><a href="https://www.financialwatchngr.com/about/">About</a></li>
<li id="menu-item-2402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2402"><a href="https://www.financialwatchngr.com/contact/">Contact</a></li>
<li id="menu-item-84189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84189"><a href="https://www.financialwatchngr.com/authors-and-contributors/">Team</a></li>
<li id="menu-item-61817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-61817"><a href="https://www.financialwatchngr.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-87681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87681"><a href="https://www.financialwatchngr.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-87682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87682"><a href="https://www.financialwatchngr.com/feedback/">Feedback</a></li>
<li id="menu-item-90439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90439"><a href="https://www.financialwatchngr.com/advertise-usd-rate/">ADVERTISE – USD RATE</a></li>
<li id="menu-item-90440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90440"><a href="https://www.financialwatchngr.com/advertise/">ADVERTISE – NAIRA RATE</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright © 2019 | <a href="https://www.financialwatchngr.com">FINANCIAL WATCH</a> 		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script type='text/javascript' id='wphb-lazy-load-js-extra'>
/* <![CDATA[ */
var wphbGlobal = {"ajaxurl":"https:\/\/www.financialwatchngr.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/55f7aae0-19b0-422d-b856-afb496b37476.js' id='wphb-lazy-load-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/bf92047f-c859-4a52-a95c-46907a2492ca.js' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/8a41c397-9fa5-4dce-a3cb-a3acbdfdf5c8.js' id='mh-scripts-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/75bc5acb-66ae-4dd6-8e21-66021f31ff37.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/94a87d87-a866-4f66-a861-9d55b6b45616.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.financialwatchngr.com/9b859093-199d-46ab-a616-f403c0dd131f.js' id='remote_sdk-js'></script>
</body>
</html>